Wavosaur home Wavosaur
Wavosaur free audio editor support forum
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Audioconfig crashes
Goto page 1, 2, 3  Next
 
Post new topic   Reply to topic    Wavosaur Forum Index -> Bug Report
 
Author Message
sync



Joined: 20 May 2007
Posts: 2

PostPosted: Sun May 20, 2007 12:37 am    Post subject: Audioconfig crashes Reply with quote

Hei

Whenever I try to open Tools -> Audio configuration = Wavosaur crashes
( wasosaur MFC Application has encountered a problem and needs to close. )

I got 2 soundsards in my rig, maby has to do with desiding/listing which to configure.

XP SP2 32bit / RME Fireface400 (Cake 6 PE) / EMU 1820m (windows default)

BR\ sync
Back to top
View user's profile Send private message
Wavosaur Main Developer
Site Admin


Joined: 30 Sep 2006
Posts: 473
Location: France

PostPosted: Tue Jun 05, 2007 5:46 pm    Post subject: Reply with quote

I have 2 sound cards on my PC I don't have this bug.
Try to desactivate a sound card to test and after the second one.
Without any other info it's difficult to understand where is the problem.
_________________
~~~~~~~~~~~~~~~~~~
Wavosaur Main Developer
~~~~~~~~~~~~~~~~~~
http://www.wavosaur.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Gloops



Joined: 17 Jun 2007
Posts: 17
Location: France

PostPosted: Sun Jun 17, 2007 11:53 am    Post subject: Wavosaur crashes Reply with quote

Hello I have the same problem and I have only one alone sound card its and it is a RME fireface 800...
Back to top
View user's profile Send private message
be



Joined: 02 Jul 2007
Posts: 7

PostPosted: Mon Jul 02, 2007 11:18 am    Post subject: Reply with quote

I have the same problem (RME Fireface 400 here), also with the newest version. Sad

That´s quite sad, cause your program seems to be really good. Hope it can be fixed some time in the future...


EDIT: Well, actually it doesn´t really crash, but nothing happens when I choose the audio config page, only the CPU load maxes and the program becomes unresponsive.
Back to top
View user's profile Send private message
Wavosaur Main Developer
Site Admin


Joined: 30 Sep 2006
Posts: 473
Location: France

PostPosted: Mon Jul 02, 2007 5:12 pm    Post subject: Reply with quote

I try to understand:
- Wavosaur crash for Options->Audio configuration, ok?


To debug we need others info:
Launch Wavosaur, load a file, a click play: what happened? Does it play correctly?
_________________
~~~~~~~~~~~~~~~~~~
Wavosaur Main Developer
~~~~~~~~~~~~~~~~~~
http://www.wavosaur.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
be



Joined: 02 Jul 2007
Posts: 7

PostPosted: Mon Jul 02, 2007 6:13 pm    Post subject: Reply with quote

Yes, Options->Audio Config.-> CPU Max->program halt

If I load and play a file after launching Wavosaur, my internal soundcard is used, so this is the default setting obviously, which works correctly. But I´d like to use my Fireface, too, of course...
Back to top
View user's profile Send private message
Wavosaur Main Developer
Site Admin


Joined: 30 Sep 2006
Posts: 473
Location: France

PostPosted: Mon Jul 02, 2007 6:17 pm    Post subject: Reply with quote

OK.

Try this:
- open wavosaur.cfg and change this
AudioOutId
1

Relaunch Wavosaur, and tell me what happened.
_________________
~~~~~~~~~~~~~~~~~~
Wavosaur Main Developer
~~~~~~~~~~~~~~~~~~
http://www.wavosaur.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
be



Joined: 02 Jul 2007
Posts: 7

PostPosted: Mon Jul 02, 2007 6:22 pm    Post subject: Reply with quote

Ahh, I found a (temporary) solution: I started Wavosaur with my Fireface turned OFF. Now it was possible to enter the audio config, where the only option was my internal soundcard. I left the config, turned ON my Fireface, and now it was possible to enter the config with my FF as an option. So I chose it and set the buffer sizes etc., and now it works alright. Only thing is, if I restart Wavosaur and go to the config page again while having my FF turned ON, the same problem occurs. So if I want to change some Audio settings, I have to turn it off and start Wavosaur etc. again.
Back to top
View user's profile Send private message
be



Joined: 02 Jul 2007
Posts: 7

PostPosted: Mon Jul 02, 2007 6:25 pm    Post subject: Reply with quote

That AuioOutID setting is already set to 1 in my cfg-file.
Back to top
View user's profile Send private message
Wavosaur Main Developer
Site Admin


Joined: 30 Sep 2006
Posts: 473
Location: France

PostPosted: Mon Jul 02, 2007 6:26 pm    Post subject: Reply with quote

OK good, but to try to correct this bug, we need other info.
_________________
~~~~~~~~~~~~~~~~~~
Wavosaur Main Developer
~~~~~~~~~~~~~~~~~~
http://www.wavosaur.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
be



Joined: 02 Jul 2007
Posts: 7

PostPosted: Mon Jul 02, 2007 6:32 pm    Post subject: Reply with quote

Ok, just ask me, if I can help...
Back to top
View user's profile Send private message
Wavosaur Main Developer
Site Admin


Joined: 30 Sep 2006
Posts: 473
Location: France

PostPosted: Mon Jul 02, 2007 6:33 pm    Post subject: Reply with quote

OK.

Try this:
- open wavosaur.cfg and change this
AudioOutId
1

Relaunch Wavosaur, and tell me what happened.
_________________
~~~~~~~~~~~~~~~~~~
Wavosaur Main Developer
~~~~~~~~~~~~~~~~~~
http://www.wavosaur.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
be



Joined: 02 Jul 2007
Posts: 7

PostPosted: Mon Jul 02, 2007 6:49 pm    Post subject: Reply with quote

Ah, you mean change it to something else than 1?

So I set it to 2, which seems to have changed the output to my internal soundcard. Then I changed it to 1 once more, making my Fireface do the job again...

Actually, as I see there are all the settings in the cfg-file easily to be changed, I can live with this bug. But if I can help you still, I will. :)
Back to top
View user's profile Send private message
Wavosaur Main Developer
Site Admin


Joined: 30 Sep 2006
Posts: 473
Location: France

PostPosted: Mon Jul 02, 2007 6:54 pm    Post subject: Reply with quote

Ok.
Complete your profile with a email adress or send us a mail at contact@wavosaur.com .
I think one of our dev should contact you to finish the debug.
Where are you from (to select a dev with tour language, if I have...)?
_________________
~~~~~~~~~~~~~~~~~~
Wavosaur Main Developer
~~~~~~~~~~~~~~~~~~
http://www.wavosaur.com
Back to top
View user's profile Send private message Send e-mail Visit poster's website
be



Joined: 02 Jul 2007
Posts: 7

PostPosted: Mon Jul 02, 2007 7:00 pm    Post subject: Reply with quote

PM sent.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Wavosaur Forum Index -> Bug Report All times are GMT
Goto page 1, 2, 3  Next
Page 1 of 3

 


Powered by phpBB © 2001, 2005 phpBB Group